How to fix NVRAM WARNING: Err = 0X10 on an Infinix Hot 2 X510

how to fix nvram warning err 0x10 on infiinix hot 2 x510

For those faced with the Wi-Fi NVRAM err 0x10, it really is nothing to worry about. Everything will work fine except this error message under Settings > Wi-Fi. We already dropped a guide on this at https://forum.hovatek.com/thread-117.html but this fix doesn’t seem to work for Infinix Hot 2 X510 users running on Android 6 (Marshmallow) so we’re dropping this guide for you guys.

How do I remove the NVRAM Warning Err 0x10 on my Infinix Hot 2 X510?

Sponsored Links

Need further assistance? Speak with a Hovatek Representative:

Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
* Upgrade to Premium Membership for Live Support: https://blog.hovatek.com/premium-membership
* Hovatek's Mobile app: https://app.hovatek.com
* Skype: Hovatek
* BBM: Hovatek
* BBM Channel: http://www.pin.bbm.com/C00403D80
* PC chat: Click "Chat With Us" at the bottom-right corner of this page
* Helpline(s): +2348149906767
* Email: [email protected]
* Facebook: https://facebook.com/hovatek


Hovatek….just a button away!

38 thoughts on “How to fix NVRAM WARNING: Err = 0X10 on an Infinix Hot 2 X510

  • March 1, 2016 at 6:00 am
    Permalink

    Excellent as usual, will try it now.

    Reply
    • March 1, 2016 at 8:30 am
      Permalink

      Let’s know how it goes for you. We’ve had 2 successful tests

      Reply
  • March 8, 2016 at 12:34 am
    Permalink

    This actually not only fixes the issues with nvram. It also fix the 3G only bug. It’s stable for me now. I’m so happy. Now I can enjoy my phone without network dropping at intervals.

    Reply
    • March 8, 2016 at 8:47 am
      Permalink

      Go to know. Don’t forget to share

      Reply
  • March 8, 2016 at 12:35 am
    Permalink

    I’m so grateful for this… You guys have been terrific. More blessings locate the problem solvers.

    Reply
    • March 8, 2016 at 8:46 am
      Permalink

      Amen. Don’t forget to share the post

      Reply
  • April 18, 2016 at 5:26 am
    Permalink

    Noah James said it “fixed” his 3G-only, was wondering what that meant but now I do.

    If you do not have 3G-only issues, DO NOT USE THIS FIX. The issue is that when you switch your network to “3G Only” or even “3G/2G” the network is never available – most times emergency mode (my case was everytime, I’m just trying to be fair). Once the network is 3G, it goes to emergency.

    I didn’t have “3G Issues” but flashing this TWRP backup, removed the NVRAM issue but gave me the “3G Issue” as a thank-you-for-using prize. Nothing fixed it, flashing back my entire OS without removing user data didn’t work. The only fix was to “Format All + Download” – yes, format the entire device.

    In my case it’s even more stressful, had to flash the Lollipop OS so I could change the IMEI to the original IMEI of the phone as the “Format All + Download” always resets my phone IMEI to an IMEI from God-knows-where.

    I still have the NVRAM issue, will just ignore it as I have for months. I’m now restoring my phone apps/settings from Titanium Backup, just wanted to let you in on my ordeal.

    Thank You

    Reply
    • April 18, 2016 at 9:05 am
      Permalink

      Thanks for the feedback. This fix works for both nvram and 3g only issues and doesn’t cause either to stop working. Yours might’ve been caused by a number of variables. Anyway, we’ll look into this.

      Reply
  • April 20, 2016 at 7:03 pm
    Permalink

    My tecno h6 is giving nvram error, and it always trip off wen working, am guessing it’s the nvram issue, I’ve flashed it like 3 times now, Pls I need ur help.

    Reply
    • April 20, 2016 at 7:14 pm
      Permalink

      do you have access to another working H6?

      Reply
  • April 20, 2016 at 7:49 pm
    Permalink

    No, but can get it…

    Reply
  • April 23, 2016 at 6:51 am
    Permalink

    I’ve done dat, is that all?

    Reply
    • April 23, 2016 at 8:54 am
      Permalink

      You’re to flash twrp to both phones.
      Boot into twrp on the working phone and backup secro and nvram then restore to the faulty one

      Reply
    • April 23, 2016 at 10:44 am
      Permalink

      let me know how it goes

      Reply
  • April 25, 2016 at 9:32 am
    Permalink

    NVRAM fixed… but the fone is still going off and hanging… please help me out

    Reply
    • April 25, 2016 at 8:47 pm
      Permalink

      what phone model? X510?

      Reply
      • April 26, 2016 at 4:34 am
        Permalink

        No, tecno h6 is d model

        Reply
        • April 26, 2016 at 7:19 am
          Permalink

          Did you flash the firmware?

          Reply
          • April 26, 2016 at 7:45 am
            Permalink

            Sure, av flashed with d firmware I download from hovatek

          • April 26, 2016 at 8:22 am
            Permalink

            Have you tried a full twrp backup of the working H6?

          • April 26, 2016 at 8:53 am
            Permalink

            Nope

          • April 26, 2016 at 4:52 pm
            Permalink

            Try that

  • December 21, 2016 at 12:34 am
    Permalink

    My infinix hot 2 still hangs/crashes and doesn’t boot into recovery even with this… Please help

    Reply
    • December 22, 2016 at 7:07 am
      Permalink

      This guide isn’t supposed to fix a hanging or crashing Hot 2. You’ll need to flash the firmware

      Reply
  • December 29, 2016 at 12:18 pm
    Permalink

    can i use this on the latest update android one 6.1 of course hot 2?! like i need to restore boot img or only nvram files? or everything?
    i have also backup from the lollipop of secro and boot etc, it could work?!
    thank you.

    Reply
    • January 7, 2017 at 8:31 pm
      Permalink

      it’ll work fine so far you restore only NVRAM

      Reply
  • January 15, 2017 at 1:39 pm
    Permalink

    i’ve try this methode. but after i flash my infinix hot 2 with that my infinix cant load. whats wrong ?

    i dont know what should i do, when i try using SN Write Tool, its always fail.

    Reply
    • January 16, 2017 at 4:48 pm
      Permalink

      does your phone have a valid Baseband?

      Reply
  • February 1, 2017 at 11:36 am
    Permalink

    could you please provide me the link for the firmware that worked with this method because it doesn’t help me a lot on my x510

    Reply
    • February 5, 2017 at 7:19 pm
      Permalink

      This was the 2+16 GB version. Did you get any error when restoring this TWRP?

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.